№ 10096 Демоверсия 2024 (Уровень: Базовый)
Операнды арифметического выражения записаны в системе счисления с основанием 19.
98897x21(19)+2x923(19)

 
В записи чисел переменной x обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления.
Основание системы счисления указывать не нужно.

s=0
for x in 'IHGFEDCBA9876543':
    s=int(f'98897{x}21',19)+int(f'2{x}923',19)
    if s%18==0:
        print(s//18)
        break